Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 13, 2026 - 12:00 CDT
Scheduled
As part of our efforts to continuously improve the services we provide to you, we are taking steps to further increase the reliability of the Smart Grid platform. On Saturday, we will be applying updates to our infrastructure to ensure the highest level of reliability.
The maintenance will be conducted in a manner that minimizes service interruption to SGS applications, however users may still experience intermittent service availability for the duration of the maintenance window.
Thank you, SGS Support
Posted Jun 12, 2026 - 08:39 CDT
This scheduled maintenance affected: Other SGS Systems, MDM, Utility Portal, and Consumer Portal.